Difference between revisions of "ZEsarUX:known bugs"

From SpecNext official Wiki
Jump to: navigation, search
(removing ZESERUse info (will get separate page))
(adding few more new bugs confirmed)
 
(13 intermediate revisions by the same user not shown)
Line 1: Line 1:
You may want also to check the official [https://raw.githubusercontent.com/GogiGoga/ZEsarUX/master/FAQ ZEsarUX FAQ] to see if you have a known issue which has solution (ZX Next is "TBBlue" type of machine).
+
You may want also to check the official [https://raw.githubusercontent.com/chernandezba/zesarux/master/src/FAQ ZEsarUX FAQ] to see if you have a known issue which has solution (ZX Next is "TBBlue" type of machine).
  
Github "master" branch at 2020-05-13 21:27CEST:
+
Github "master" branch at 2022-05-14 01:15 CEST (commit 773887d3e62db7530eefda7b0c1991a51a9519e5, version 10.1):
* sprites rendering is at "4B type" level (no anchor/relative sprites or scaling) (5B init is correctly accepted but doesn't render the extra features)
 
* 4bpp sprites are not supported
 
* sprites rendering is not one-scanline-buffer delayed and all changes in sprites affect current scanline
 
* Layer 2 displays shadow variant (NextReg $13) when the "shadow" mapping is enabled
 
* Layer 2 extra memory mapping controlled by {{PortNo|$123B}} works only in core2.x way.
 
* Layer 2 does not support "priority" bit in L2 colors
 
* palette read (NextReg $41 + $44 produces wrong results)
 
* clip windows control $1C has old layout of bits, thus producing incorrect readings
 
* NextRegs $09 reads wrong values (the more "esoteric" ones like expansion bus related are not part of this test/list)
 
* NextReg $09 function bit "Reset divmmc mapram bit (port 0xe3 bit 6)" is not implemented
 
 
* missing Nextreg $64 "video line offset" (core 3.1.5)
 
* missing Nextreg $64 "video line offset" (core 3.1.5)
* tilemode gfx/map address read (NextReg $6E + $6F) does return original value without top bits set to zero
 
* DMA: too many differences to list, but most crucial: CONTINUE is not supported, slow "burst" functionality is not complete, legacy Z80 mode is not implemented
 
 
* blending modes are not implemented
 
* blending modes are not implemented
* ULA scroll is not at new NextReg $26, $27 (but still shared with LoRes offset registers)
+
* DMA: too many differences to list, but most crucial: slow "burst" functionality is missing, CONTINUE is not supported, legacy Z80 mode is not implemented, all transfers are "instant", dmaDebug.sna test does "reset" machine after ENABLE command (didn't look what exactly is broken about the last one)
* ULA+tilemode does not support stencil mode
+
* ULA scroll doesn't scroll per pixel on X-axis, but per 8px (char)
 +
* ULA half-width scroll is not implemented
 +
* ULA scroll clipping on Y-axis is not working correctly
 +
* sprite rendering-priority (b6 in NextReg $15) is not implemented
 +
* relative sprites don't wrap correctly around 512x512 coordinate space in extreme cases (8x scale and some positions)
 +
* sprites rendering is not one-scanline-buffer delayed and all changes in sprites affect current scanline
 +
* NextRegs $09 reads wrong values
 +
* <del>tilemode gfx/map address read (NextReg $6E + $6F) does return original value without top bits reset to zero</del>(this is now probably correct since core3.1.10? But bank7 is not supported yet of course)
 
* audio has "clicks" and noise on many platforms, although YMMV
 
* audio has "clicks" and noise on many platforms, although YMMV
 +
* modifications to NextRegs done in copper propagate to rendering usually only once per scanline, usually retroactively for full scanline when triggered in h-blank area (palette changes, X/Y offsets, etc)
 +
* when running without the full NextZXOS card image, the esxdos services are provided by the emulator itself, which does not implement all of them, and they don't always return the state described by the NextZXOS documentation
 +
* missing all(?) features/changes of cores after version 3.1.5 (the emulator itself reports as core 3.1.11, but I haven't find any functionality related to the changes in real cores)
 +
* Z80: EI instruction doesn't inhibit accepting masked interrupt until next instruction is executed (after debugging: it does inhibit it, but just delays acceptance infinitely, so interrupt may be accepted even after the /INT signal is over)
 +
* Z80: extra IX/IY prefix is wrongly processed and with even number of prefixes the next instruction is using HL instead of IX/IY
 +
* Z80: (should not affect any ZX SW, just emulation accuracy) ccf/scf doesn't produce stable outcome in undocumented flags
 +
* Z80: (should not affect any ZX SW, just emulation accuracy) block instruction flags while repeating are incorrect
 +
* in linux trying to open "Debug CPU" window will smash the stack and crash the emulator, you can work around it by using "-fno-stack-protector" during compilation to continue running even with damaged stack content (it seems to be working, but expect unexpected then).
 +
 +
Untested since 10.0-RC (may be already fixed, probably not):
 +
* ULA+tilemode does not support stencil mode, and transparency fallback color is not used in some edge cases (disabled ULA + clipped tiles)
 
* tilemode doesn't wrap in memory the same way as HW (when gfx/map address is toward end of Bank 5)
 
* tilemode doesn't wrap in memory the same way as HW (when gfx/map address is toward end of Bank 5)
 
* direct loading of NEX file doesn't init the machine in the same way as NEXLOAD from NextZXOS (it's close, but few things are different)
 
* direct loading of NEX file doesn't init the machine in the same way as NEXLOAD from NextZXOS (it's close, but few things are different)
* screen saver of NextZXOS will "crash" the emulated machine (not emulator itself)
 
* modifications to NextRegs done in copper propagate to rendering usually only once per scanline, usually retroactively for full scanline when triggered in h-blank area (palette changes, X/Y offsets, etc)
 
* when running without the full NextZXOS card image, the esxdos services are provided by the emulator itself, which does not implement all of them, and they don't always return the state described by the NextZXOS documentation
 
* missing Nextreg $8F (core 3.1.6)
 
  
Official 8.1 release has also these:
+
Fixed since 10.0-RC final:
* registers from core 3.1.1+ onward are not implemented at all
+
* <del>Layer 2 does not support "priority" bit in L2 colors</del>
* altROM next register does not work correctly and core 3.1.3 does further change it
 
* Layer 2 modes 320x256x8bpp and 640x256x4bpp are not implemented
 
* screen saver of NextZXOS will "crash" the emulated machine (not emulator itself)
 
* monochrome tilemode has wrong colours (and overall attribute usage)
 
  
 
Other Issues (not a bug):
 
Other Issues (not a bug):
 
* 28MHz mode requires quite powerful PC to emulate it smoothly, "lagging" emulator menu/etc is likely to happen in 28MHz mode and unfit for many development purposes.
 
* 28MHz mode requires quite powerful PC to emulate it smoothly, "lagging" emulator menu/etc is likely to happen in 28MHz mode and unfit for many development purposes.
 
* don't use "--enable-esxdos-handler" option together with running NextZXOS from full MMC card image - it will clash with the MMC functionality
 
* don't use "--enable-esxdos-handler" option together with running NextZXOS from full MMC card image - it will clash with the MMC functionality

Latest revision as of 20:21, 1 July 2022

You may want also to check the official ZEsarUX FAQ to see if you have a known issue which has solution (ZX Next is "TBBlue" type of machine).

Github "master" branch at 2022-05-14 01:15 CEST (commit 773887d3e62db7530eefda7b0c1991a51a9519e5, version 10.1):

  • missing Nextreg $64 "video line offset" (core 3.1.5)
  • blending modes are not implemented
  • DMA: too many differences to list, but most crucial: slow "burst" functionality is missing, CONTINUE is not supported, legacy Z80 mode is not implemented, all transfers are "instant", dmaDebug.sna test does "reset" machine after ENABLE command (didn't look what exactly is broken about the last one)
  • ULA scroll doesn't scroll per pixel on X-axis, but per 8px (char)
  • ULA half-width scroll is not implemented
  • ULA scroll clipping on Y-axis is not working correctly
  • sprite rendering-priority (b6 in NextReg $15) is not implemented
  • relative sprites don't wrap correctly around 512x512 coordinate space in extreme cases (8x scale and some positions)
  • sprites rendering is not one-scanline-buffer delayed and all changes in sprites affect current scanline
  • NextRegs $09 reads wrong values
  • tilemode gfx/map address read (NextReg $6E + $6F) does return original value without top bits reset to zero(this is now probably correct since core3.1.10? But bank7 is not supported yet of course)
  • audio has "clicks" and noise on many platforms, although YMMV
  • modifications to NextRegs done in copper propagate to rendering usually only once per scanline, usually retroactively for full scanline when triggered in h-blank area (palette changes, X/Y offsets, etc)
  • when running without the full NextZXOS card image, the esxdos services are provided by the emulator itself, which does not implement all of them, and they don't always return the state described by the NextZXOS documentation
  • missing all(?) features/changes of cores after version 3.1.5 (the emulator itself reports as core 3.1.11, but I haven't find any functionality related to the changes in real cores)
  • Z80: EI instruction doesn't inhibit accepting masked interrupt until next instruction is executed (after debugging: it does inhibit it, but just delays acceptance infinitely, so interrupt may be accepted even after the /INT signal is over)
  • Z80: extra IX/IY prefix is wrongly processed and with even number of prefixes the next instruction is using HL instead of IX/IY
  • Z80: (should not affect any ZX SW, just emulation accuracy) ccf/scf doesn't produce stable outcome in undocumented flags
  • Z80: (should not affect any ZX SW, just emulation accuracy) block instruction flags while repeating are incorrect
  • in linux trying to open "Debug CPU" window will smash the stack and crash the emulator, you can work around it by using "-fno-stack-protector" during compilation to continue running even with damaged stack content (it seems to be working, but expect unexpected then).

Untested since 10.0-RC (may be already fixed, probably not):

  • ULA+tilemode does not support stencil mode, and transparency fallback color is not used in some edge cases (disabled ULA + clipped tiles)
  • tilemode doesn't wrap in memory the same way as HW (when gfx/map address is toward end of Bank 5)
  • direct loading of NEX file doesn't init the machine in the same way as NEXLOAD from NextZXOS (it's close, but few things are different)

Fixed since 10.0-RC final:

  • Layer 2 does not support "priority" bit in L2 colors

Other Issues (not a bug):

  • 28MHz mode requires quite powerful PC to emulate it smoothly, "lagging" emulator menu/etc is likely to happen in 28MHz mode and unfit for many development purposes.
  • don't use "--enable-esxdos-handler" option together with running NextZXOS from full MMC card image - it will clash with the MMC functionality